How to Configure SendEmail Functionality

All posts which do not fit into any other sections of the forum.

Moderator: admin

Re: How to Configure SendEmail Functionality

Postby Nikolay.Gekht » Mon Dec 27, 2010 2:03 pm

In this case this AT&T (if your iphone is not unlocked and is used on AT&T provider) KB article is for you;
http://www.wireless.att.com/support_sta ... B5892.html
Nikolay.Gekht
FXCodeBase: Base Builder
 
Posts: 1222
Joined: Wed Dec 16, 2009 6:39 pm
Location: Cary, NC

Re: How to Configure SendEmail Functionality

Postby Caalador » Thu Jan 13, 2011 12:33 pm

I got this error when not specifying an account or password when trying to send mail through Exchange Server (i have a receive connector on port 25 that has basic auth enabled for anonymous users)

Failed to send an email with notification to 'xxxxxx', subject: 'xxxxxx'.
Details:The authentication type used on the specified SMTP server is not supported by Marketscope.


I disabled "TLS Before Basic Authentication" on the Receive Connector in my Exchange 2010 server and hope this will fix it, if you don't hear from me, it's fixed ;-)
Caalador
 
Posts: 20
Joined: Tue Nov 23, 2010 12:03 am

Re: How to Configure SendEmail Functionality

Postby Caalador » Fri Jan 14, 2011 10:34 am

Nope, that didn't work...I tried a lot of different configs but it seemed Marketscope couldn't talk to my exchange server.

I added an SMTP virtual instance to my IIS webserver and let it go through there, IIS then passed it onto the exchange server and it works fine now...

Why can't marketscope talk to an exchange server over port 25? It wasn't blocked by a firewall or ISP, it's all local.
Caalador
 
Posts: 20
Joined: Tue Nov 23, 2010 12:03 am

Re: How to Configure SendEmail Functionality

Postby Nikolay.Gekht » Tue Jan 18, 2011 3:35 pm

I'll point the development team to this problem. I hope they will be back with the solution soon.
Nikolay.Gekht
FXCodeBase: Base Builder
 
Posts: 1222
Joined: Wed Dec 16, 2009 6:39 pm
Location: Cary, NC

Re: How to Configure SendEmail Functionality

Postby craige » Thu Jan 20, 2011 2:08 am

HEY GUYS

I can not use the Email function even though I followed your instruction

I use the demo account to try, and I have two email address.

1.heyongping8115@gmail.com
2.heyongping8115@sina.com

I make the first email address to send the mail to the second email address when the stratigy signal occured, but I failed.

what should I do with this two email address, do I miss something?

thanks if someone could help me

best regards
craige
 
Posts: 51
Joined: Thu Dec 23, 2010 9:54 pm

Re: How to Configure SendEmail Functionality

Postby Apprentice » Thu Jan 20, 2011 5:51 am

Complete description of how to configure email can be found here.
I hope this will help .

viewtopic.php?f=31&t=3034
User avatar
Apprentice
FXCodeBase: Confirmed User
 
Posts: 19186
Joined: Thu Dec 31, 2009 11:59 am
Location: Zagreb, Croatia

Re: How to Configure SendEmail Functionality

Postby Victor.Tereschenko » Fri Jan 21, 2011 12:44 am

craige wrote:HEY GUYS

I can not use the Email function even though I followed your instruction

I use the demo account to try, and I have two email address.

1.heyongping8115@gmail.com
2.heyongping8115@sina.com

I make the first email address to send the mail to the second email address when the stratigy signal occured, but I failed.

what should I do with this two email address, do I miss something?

thanks if someone could help me

best regards

Try to specify SMTP server address with a port number. smtp.gmail.com:587 works well on my PC
“There are only three sports: bullfighting, motor racing, and mountaineering; all the rest are merely games.” (c) Ernest Hemingway
Victor.Tereschenko
FXCodeBase: Confirmed User
 
Posts: 120
Joined: Fri Nov 19, 2010 8:55 am

Re: How to Configure SendEmail Functionality

Postby craige » Sun Jan 23, 2011 7:22 pm

Hey Victor

thanks for the info

I will have a try

thank you

Craige
craige
 
Posts: 51
Joined: Thu Dec 23, 2010 9:54 pm

Re: How to Configure SendEmail Functionality

Postby ak_nomiss » Wed Apr 27, 2011 7:57 pm

Hello all ,
I have followed all the steps on this post and what happen is I only get some of the emails from the strategies, most time instead I get the emails I getting this message: " Failed to send an email with notification to 'abc@abc.com', subject: 'Enter Long Position'.
Details:An error occurred during communication with the SMTP server. Please make sure that the SMTP server settings in Strategies Options and the e-mail address specified in the strategy properties are correct. "
I am very sure that I put everything right in strategy options because I have receive SOME of the email, its like out of 20 alerts it will send 1 email success, I also test multi strategies into M1 and M30 timeframe and let it run overnight the problem still the same.
ak_nomiss
 
Posts: 18
Joined: Mon Nov 08, 2010 7:50 pm

Re: How to Configure SendEmail Functionality

Postby sunshine » Thu Apr 28, 2011 6:26 am

ak_nomiss wrote:Hello all ,
I have followed all the steps on this post and what happen is I only get some of the emails from the strategies, most time instead I get the emails I getting this message: " Failed to send an email with notification to 'abc@abc.com', subject: 'Enter Long Position'.
Details:An error occurred during communication with the SMTP server. Please make sure that the SMTP server settings in Strategies Options and the e-mail address specified in the strategy properties are correct. "
I am very sure that I put everything right in strategy options because I have receive SOME of the email, its like out of 20 alerts it will send 1 email success, I also test multi strategies into M1 and M30 timeframe and let it run overnight the problem still the same.


Hi,
Could you specify your email provider (gmail, yahoo, etc.)? Could you please also answer:
1) Have you ever had problems with sending regular emails (not alert emails from Marketscope) through this email provider?
2) Did you try to send alert emails through other email providers?
sunshine
 

PreviousNext

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 3 guests