Bug Reporting

All posts which do not fit into any other sections of the forum.

Moderator: admin

Re: Bug Reporting

Postby robocod » Tue Sep 26, 2017 10:37 am

I have discovered a bug with the latest version of Trading Station. The bug affects trading strategies.

When submitting a trade order, e.g. market order, using the terminal:execute() function, I am checking that it was executed properly in the AsyncOperationFinished() call-back (or ExtAsyncOperationFinished() when the helper file is used).

ExtAsyncOperationFinished(cookie, success, message)

According to the SDK, and previously this worked, the "message" should be the orderId of a successfully completed order.

Extract from SDK help file...
Code: Select all
cookie
 An integer value specified for the operation in the execute() method.
 
successful
 A boolean flag indicating whether the order has been successfully executed on the server.
 
info
 A string, which contains:

[in case successful is true] The order identifier for the the create order commands or an empty string in all other cases.

[in case successful is false] The error text received from the server.
 


The "message" (which was called "info" in the above extract from SDK) used to be the orderID, which could be saved for reference, displayed, etc. etc. now is coming over as "nil".

This has caused my strategies to fail, which are expecting a valid order number here.

See screenshot 1 (from TradingStation)...
screenshot1.png


The back-tester is still working as it used to do. See screenshot 2 (from back-tester)...
screenshot2.png


Please see the attached test code (which is basically a copy of a code segment from the SDK).
test.lua
(2.59 KiB) Downloaded 461 times


Any idea what happened? Is it problem with TS2 or is the server somehow now sending back the order id?
User avatar
robocod
FXCodeBase: Graduate
 
Posts: 298
Joined: Thu May 10, 2012 4:25 pm

Re: Bug Reporting

Postby Konstantin.Toporov » Tue Sep 26, 2017 3:24 pm

We will investigate.
Sorry for the inconvenience.
Konstantin.Toporov
 
Posts: 72
Joined: Mon Aug 31, 2015 10:16 am

Re: Bug Reporting

Postby Marcello » Wed Sep 27, 2017 11:09 am

I'm experiencing the same issue, and it is generating me serious problems with strategies!!
Marcello
 
Posts: 20
Joined: Mon Jul 25, 2016 4:09 pm

Re: Bug Reporting

Postby Konstantin.Toporov » Wed Sep 27, 2017 11:55 am

We are apologizing for that.
We released a dev version of FXTS with this fix.
viewtopic.php?f=30&t=65124.
Konstantin.Toporov
 
Posts: 72
Joined: Mon Aug 31, 2015 10:16 am

Re: Bug Reporting

Postby Marcello » Fri Sep 29, 2017 12:04 am

Thanks Konstantin, I'm looking forward for the final fix!!
Marcello
 
Posts: 20
Joined: Mon Jul 25, 2016 4:09 pm

Failed to load profile

Postby SirOrigami » Fri Nov 24, 2017 3:36 pm

SOLVED:
FXCM trading station desktop:
trying to load my profile:

"Failed to load profile from the specific file"

i have tried reinstall, creating new profiles,
different computer.


Solution:
1. Uninstall trading station
2. Delete folder from "program files"(candleworks)
3. Delete appdata folder tradingstation (candleworks)
4. Registry clean with CCleaner
5. Reinstall Trading Station
Last edited by SirOrigami on Tue Nov 28, 2017 2:13 pm, edited 1 time in total.
SirOrigami
 
Posts: 7
Joined: Fri Nov 24, 2017 2:48 pm

Re: Bug Reporting

Postby Apprentice » Sun Nov 26, 2017 9:13 am

Can you please send it to my email.
Please, add a link to this topic.
User avatar
Apprentice
FXCodeBase: Confirmed User
 
Posts: 19244
Joined: Thu Dec 31, 2009 11:59 am
Location: Zagreb, Croatia

Re: Bug Reporting

Postby SirOrigami » Sun Nov 26, 2017 1:17 pm

Apprentice wrote:Can you please send it to my email.
Please, add a link to this topic.



Profile sent: sirorigami
SirOrigami
 
Posts: 7
Joined: Fri Nov 24, 2017 2:48 pm

Re: Bug Reporting

Postby Avignon » Sun Nov 26, 2017 6:28 pm

(I use google translate)

Hello,

It's odd that an early week starts on a Saturday, especially the market is closed.

version 01.15.071017


Capture bug semaine.png



Regards.
Avignon
 
Posts: 97
Joined: Mon Nov 17, 2014 3:54 am

Re: Bug Reporting

Postby Apprentice » Sun Nov 26, 2017 6:58 pm

Profile was sent to the development team.
User avatar
Apprentice
FXCodeBase: Confirmed User
 
Posts: 19244
Joined: Thu Dec 31, 2009 11:59 am
Location: Zagreb, Croatia

PreviousNext

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 3 guests