Indicore debugger not loading instruments

Various questions related to programming, testing, deployment and support.

Moderator: admin

Indicore debugger not loading instruments

Postby Fartlek » Mon Jul 13, 2020 7:15 am

Hi, devs!

I was in the middle of coding up an indicator where everything had been going fine when suddenly I got this message pop up in a dialog box:

Cannot load information about instruments from the application configuration.
Error: Failed to update instruments: Instrument catalog file parsing failed. Tag 'timeframe' does not contain attribute 'start-date' or its content is empty.

Now this pops up every time I open Indicore 3 Lua Editor/Debugger. If I check out Tools -> Instrument List I can see all the instruments are in "Available instruments:" and the "All instruments:" group is empty. In Tools -> Quotes Manager -> Remove Quotes there is "All quotes", but this is 0 bytes. If I open an indicator to work on and try to simulate it, when choosing an instrument price source I get the notice:
There are no InstrumentInfo options in the application configuration

Followed by
NULL or empty string in parameters is not allowed

and then there are no quote manager source to choose.

I've tried uninstalling the editor and removing the remaining files from C:\Gehtsoft, restarting my computer and then installing the editor, but I still get the same error about the catalog file as soon as I open the editor for the first time (and every time).

Can anyone suggest a way to fix this?
Posts: 4
Joined: Wed Jun 17, 2020 11:59 am

Re: Indicore debugger not loading instruments

Postby loseend » Mon Jul 13, 2020 11:27 am

Hi, I've got exactly the same issue with indicore debugger with the same pile of exact same error messages. And also by today. Very odd.

Before I found your topic here I thought I might have done something stupid on my computer that messed up with indicore.

In contrast to the older versions of indicore debugger that requires adjustments in the quote manager before using it indicore 3.0 and newer addressing the quotes automatically - so I don't see any 'application configuration' that has to be adjusted.

I did a deep uninstallation of the debugger and reinstalled it several times including the IntegrationSDK - but the error remains.

I hope someone has the clue.
Posts: 56
Joined: Tue Jul 31, 2018 12:37 pm

Re: Indicore debugger not loading instruments

Postby escape » Mon Jul 13, 2020 2:22 pm


I'm also having this problem since trading opened on Sunday.

It's probably not our implementations, as the ForexConnect 1.6.3 samples are throwing the same errors.

Would be nice to have an idea of when it might be resolved.

Posts: 2
Joined: Sat May 02, 2020 5:49 pm

Re: Indicore debugger not loading instruments

Postby Fartlek » Tue Jul 14, 2020 10:02 am

This is working for me, now.

This is what I did, but it might just be a coincidence:

[*] Close the debugger
[*] Delete ONLY
Code: Select all
(as I had re-installed the debugger, this was the only file in that folder since I had no instrument history). I had to end the debugger task using Task Manager before I could delete the file.
[*] launch the debugger

Previously I had tried deleting everything from C:\Gehtsoft\IndicoreSDK3\History, but that hadn't worked for me. Deleting the
Posts: 4
Joined: Wed Jun 17, 2020 11:59 am

Return to Development

Who is online

Users browsing this forum: No registered users and 1 guest